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Broadcast Screen 
DyKnow Step-by-Step 

 

1.  From the “Session” or “Monitor” tab, click “Broadcast Screen.” 
 

 

 
 

 

 
 

2. Choose if you would like to broadcast your computer (This Computer) or choose a specific 
student’s machine to broadcast. 
 

 
 

(NOTE: Only your computer – “This Computer” – can be broadcast via the Monitor tab. When 
you click on “Broadcast Screen” from the Monitor tab, the above box will not appear. You will 
automatically be broadcasting your screen to the class.) 
 

3. Click “Start Broadcast.” 
 

4. Once you have started the broadcast, you can move between programs you want your students 
to see on their screen. 
 

 
 

This box will appear in your upper left hand corner as you navigate between programs. Click 
“Capture Screenshot” to insert a picture of your current screen in DyKnow. To end the 
broadcast, click “Stop Broadcast.” 
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Follow Me 
DyKnow Step-by-Step 

 
To synchronize the participant slide with the teacher slide (so they see what you see): 
 
1.  From the “Session” tab, click the “Follow Me” icon. 

 
A checkmark will appear over the icon indicating follow me is active. When the teacher 
changes slides, students who have not manually “tacked-in “ with their pushpin will change 
slides as well. 

 
2.  To lock students on your slide and prevent them from navigating elsewhere, click the “Follow  

Me” dropdown arrow and click “Lock Follow Me” on. A lock symbol will appear on the icon 
indicating follow me is locked. 

 

 
 

 

 

 
When follow me is locked, your students will ONLY see the slide you are viewing in your  
session. If they have been taking notes in other slides, they may be worried that this work has 
“disappeared.” Not to fear, once you unlock follow me, they will see all their slides again. 

 
3.  To give manual navigation back to your students, click the “Follow Me” icon again (on the  

“Session” tab). The checkmark or lock symbol will disappear indicating follow me has been  
turned off. 
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Backgrounds 
DyKnow Step-by-Step 

 
To insert a background on your slide: 
 
1. From the “Insert” tab, click the “Background” icon. 

 
2.  Choose your desired category (graphs, maps, paper, tables, templates) followed by your  

desired background image (see options below). 
 

Graphs Maps Paper Tables 
4 XY Grids (Positive 
Axis Only) 
Graph Paper (Large) 
Graph Paper (Medium) 
Graph Paper (Small) 
XY Grid (Positive Axis 
Only) 
XY Grid (Large) 
XY Grid (Medium) 
XY Grid (Small) 
Trig Coordinate Plane 1 
Trig Coordinate Plane 2 
Trig Unit Circle 

U.S. Map 
World 
Map 

Handwriting Paper 
(Large) 
Handwriting Paper 
(Medium) 
Handwriting Paper 
(Small) 
Engineering Paper 
Lined Paper 
Horizontal Lines 
Vertical Lines 
Music Paper 
Music Paper (Blank) 
 

Numbers Table 
Numbers Table (Blank) 
Multiplication Table 
Multiplication Table 
(Blank) 
Periodic Table 
 

 
Templates 

Alphabet (Uppercase and Lowercase) 
Alphabet Chart (A-M Lowercase) 
Alphabet Chart (A-M Uppercase) 
Alphabet Chart (N-Z Lowercase) 
Alphabet Chart (N-Z Uppercase) 
Balance Sheet 
Cash Flow Statement 
Clock Face 
General Journal 
General Ledger 
Income Statement 
 
3.  (Optional) Check the “Create all new panels with this background” box if you want to show  

that background on all slides. 
 
4.  Click “OK.” 
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Images 
DyKnow Step-by-Step 

 
To insert an image via the “Screen Grab” feature: 
 
1.  From the “Insert” tab, click the “Screen Grab” icon. (DyKnow will minimize  and a “Screen 
Grab” menu will appear in the upper left corner of the screen.) 

 

 
 

 

 
 

2.  While on the “Pointer” tool, browse on your computer to the desired image. 
 
3.  Click “Select Region.” 
 
4.  Click and drag over the region of your screen to be captured into DyKnow. 
 
5. Click “Capture.” (This will appear at the bottom right hand corner of the region you have  

selected. 

 
 
To insert an image from a file: 
 
1.  From the “Insert” tab, click the “Image from File” icon. 

 
 
2. Browse for the desired image and click “Open.” 
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Images (continued) 
DyKnow Step-by-Step 

 
To insert an image from the “Palette”: 
 
1.  From the “Insert” tab, click the “Palette” icon. 

 
2.  Choose your category from the drop down menu (Circuits, General, Math, Music). 

 
3.  Choose the image you want to insert. 
 
4.  Click on the slide. 
 
5.  Repeat steps three and four for multiple images. 
 
6.  Click close. 
 

NOTE: If you have a folder containing your favorite .JPEG or .GIF images, you can add that 
folder as a category using the custom button. 
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Manage Panels (Submit, Collect, Return) 
DyKnow Step-by-Step 

 
Managing Submitted Panels 

What students do What teachers do 
1.  Complete the homework or activity. 
2.  From the “Home” tab, click “Submit Panel”  

(NOTE: Students can submit multiple  
panels if necessary). 

After students have submitted their work: 
1.  From the “Home” or “Session” tab, click  

“Manage Panels. 
2.  Check the box next to the names of the  

users you would like to manage. 
3.  Select the dropdown menu at the bottom to  

append the submitted panels to a “New  
Notebook” (in order to grade later) OR to  
the “Current Session Notebook” for  
everyone to see. 

4.  Click “Append.” 
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Manage Panels (Submit, Collect, Return) – (Continued) 
DyKnow Step-by-Step 

 
Managing Retrieved Panels 

What students do What teachers do 
1.  Complete the activity as directed (watching  

the clock they will see at the bottom of their  
screen if the timer is set) 

As the students complete the activity: 
1.  Set the DyKnow Timer for timed activities. 
2.  From the “Home” or “Session” tab, click  

“Manage Panels.” 
3.  Click the “Retrieve Panels” tab. 
4.  Select the individual or range of panels to  

collect and whether to collect them  
anonymously.  

5.  Check the box next to the names of the  
users you would like to collect or use the  
random retrieval functionality. 

6.  Select the dropdown menu at the bottom to  
append the collected panels to a “New  
Notebook” (in order to grade later) or to the  
“Current Session Notebook” (for everyone  
to see). 

7.  Click “Retrieve.” 
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Manage Panels (Submit, Collect, Return) – (Continued) 
DyKnow Step-by-Step 

 
Return Panels 

What teachers do What students do 
1.  Sign-in to DyKnow. 
2.  Open and mark up previously saved  

submitted or retrieved work in DyKnow. 
3.  From the “Authoring” tab, click “Return  

Panels.” 
4.  Select the class the work should be returned  

to. 
5.  (Optional) Give the returned work a name  

(i.e. 3/13/2010 – English Essay). 
6.  Click “OK.” 

1.  Sign-in to DyKnow. 
2.  Navigate to “My DyKnow” tab and click  

the class name for the class that work  
has been returned to. 

3.  Click on the notebook name to open and  
view it. 
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Poll Participants 
DyKnow Step-by-Step 

 
To create a poll before class, in PowerPoint: 
 
1.  Open up the desired PowerPoint file and navigate to the slide the poll will be added to. 
 
2.  Click the “DyKnow” tab. 
 
3.  Click the “Insert New” button. 

 
 

4.  Check the box next to the type of poll you wish to give (multiple choice, true/false, etc.) and  
click “Next.” 

 
 

5.  Type in the question and possible answers. 

 
 
6.  Click “Insert Poll.” 
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Poll Participants (continued) 
DyKnow Step-by-Step 

 
To create a poll before class, in DyKnow: 
 
1.  Open up the desired DyKnow notebook and navigate to the slide the poll will be added to. 
 
2.  From the “Insert” tab, click the “Insert Poll” button. 

 
 

3.  Check the box next to the type of poll you wish to give (multiple choice, true/false, etc.) and  
click “Next.” 

 
 
4.  Type in the question and possible answers. 

 
5.  Click “Insert.” 
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Poll Participants (continued) 
DyKnow Step-by-Step 

 
Administering polls that were created before class: 
 
1.  Add the slide from your Prepared Notes containing the poll to the session. 

 
 
2.  Press the “Launch” button under the poll. 
 
3.  After you have received all of the answers, click “Results.” 
 
4.  Choose how you wish to see the results (table, pie chart, etc.) and click “Capture” to display  

the results on the panel. 
 

5.  (Optional) Save the results as a .csv file by clicking “Save.” 
 
To create and send a poll during class: 
 
1.  From the “Home” or “Session” tab, click “Poll Participants.” 
 
2.  Check the box next to the type of poll you wish to give (multiple choice, true/false, etc.) and  

click “Next.” 
 

3.  Type in your question and answers here. 
 
4.  Click “Next.” 
 
5.  When ready to view results, click “Results.” 
 
6.  Choose how you wish to see the results (table, pie chart, etc.) and click “Capture” to display  

the results on the panel. 
 
7.  (Optional) Save the results as a .csv file by clicking “Save.” 
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Share Control 
DyKnow Step-by-Step 

 
1.  From the “Home” or “Session” tab, click “Share Control.” 

 
 

2. Select the student(s) you wish to give control and click “OK.” 

 
3.  That student now has control of the panel and everyone else can see what he/she is writing. 
 
4.  To take away control, follow the steps above and unselect all students, then click “OK.” 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Students’ 
names 
with 

appear 
here. 
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Starting a Class in DyKnow 
DyKnow Step-by-Step 

 
1.  Sign in to DyKnow and click “Start Session” next to the class for which you would like to  

begin a session. 

 
 

OR 
Click “Start Session” on the “Session” ribbon. 

 
 
2. Choose your “class” and click on “…” to browse for any “prepared notes” for the session. 

 
 

 Make sure you have the “Monitor User Workstations by class enrollment” if you also wish  
to use DyKnow Monitor. Then, click “OK” to start your session. 
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Starting a Class in DyKnow (continued) 
DyKnow Step-by-Step 

 
3.  Students will need to join your session by signing on to DyKnow (using their network login  

information) and clicking “Join Session” next to your class. NOTE: “Join Session” will only 
appear after you have started the session. Also, if a student isn’t signed into DyKnow, they 
will not see this option. 

 
4. If you have prepared panels, bring in your first prepared panel by click the space bar or the  

“Append Next Prepared Panel” button. 

 
 
5. To bring in a blank panel, click the “Append Blank Panel” button. 

 
 
6.  You will see a variety of icons in the “Viewer” panel on the lower-right hand side of your  

screen. 
 

  
Private Notes: Any notes you might see during a session, but your students would not (similar  

to the “Notes” section in a PowerPoint). 
Session List: the students who have joined your session 
Chat: allows you to open a “chat session” from Teacher-to-Student only, from Student-to- 

Teacher only, or between all participants. 
Activity Level:  
Prepared Notes: will show you the slides in your session; if you wish to jump ahead to a slide,  

scroll to the slide you wish to append, click on it, and then press the space bar 
or “Append Next Panel” button. 

Filmstrip: will show you the slides you have appended to your session 
Animation Timeline: will show you any animation you have added to a panel (similar to  

animation in PowerPoint, but with fewer options) 
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Starting a Class in DyKnow (continued) 
DyKnow Step-by-Step 

 
7.  You will see a variety of options in the Session tab to use special features. 

 
 
8.  To end your session, click on “End Session” on the “Session” tab. NOTE: You will have to  

separately stop monitoring your students through the “Monitor” tab. 
 
9.  Repeat this process for your next session or “Sign Off” in the Application Menu to exit  

DyKnow. 
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Text Box 
DyKnow Step-by-Step 

 
To insert a new text box: 
 
1. From the “Home,” “Insert” or “Authoring” tab, click “Text Box.” 

 

 
 

 

 

 

 
 

 
2. Click the position on the panel you want to insert the text box. 
 
3. Type your text. 
 
4. (Optional) Resize or move the text box by clicking on the dotted lines surrounding the text  

box. 
 
5.  Click outside the dotted lines to plant the text on the panel. 
 
To edit an existing textbox: 
 
1. From the “Home” tab, click the “Selection Square.” 

 

 
 

 

 

 
2. Single click the text you want to edit. 
 
3. Type your changes. 
 
4. Click outside the dotted lines to plant the text on the panel. 
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Work in Groups 
DyKnow Step-by-Step 

 
1.  From the “Session” tab, click on “Work in Groups.” 
 
2.  Check the box next to the names of the students you want to be in a group and click “New  

Group.” Continue until you have all of your groups. (NOTE: If students have not joined your  
session, you will not be able to place them in groups.) 

 
3.  (Optional) Randomly group students by selecting the number of work groups and click  

“Random.” 
 
4.  (Optional) You can choose to limit work group collaboration to specific panels by selecting a  

panel range. 
 
5.  (Optional) You can choose to save the groups if you will be using them again by clicking  

“Save.” 
 
6.  (Optional) If you have previously saved groups you wish to use, click “Load.” 
 
7.  After you have all of your groups assembled, click “OK.” 
 
8.  To take students out of work groups, click “Work in Groups,” then “Ungroup All” and “OK.” 


